Topic Options
#2412367 - 12/02/17 05:18 PM 2001 Ram Van electrical issue
cudaman1969 Offline
master

Registered: 01/25/04
Posts: 3862
Loc: fredericksburg,va
Just bought the van, owner said he had to replace the three connectors to the computer because of bad ends. Well after buying I took the tape off ( a mess) and found he or whoever used regular crimp connectors (the ones u crimp with the pliers) also some of the wires colors don't match. Connectors are new looking (replacement?) Going to pick a part to try to find a van harness, but might b just as bad being that old, would one off a truck work if I don't find the van one? Checked and a new harness from Chrysler is over $1000. If no luck finding one I will go back and solder each end then shrink tape to seal but the colors got me worried so where would I find a schematic of the wirring routing? Thanks

Top
#2412485 - 12/02/17 08:36 PM Re: 2001 Ram Van electrical issue [Re: cudaman1969]
mgoblue9798 Offline
member

Registered: 03/16/10
Posts: 127
Loc: Atlanta, GA
Buy yourself a factory service manual on ebay. It will save you a lot of time trying to trace wiring and pay for itself. Look for your harness on www.car-part.com


Edited by mgoblue9798 (12/02/17 08:37 PM)

Top
#2413364 - 12/04/17 10:03 PM Re: 2001 Ram Van electrical issue [Re: cudaman1969]
poorboy Offline
master

Registered: 01/19/03
Posts: 6063
Loc: Freeport IL USA
Does the van run?

Might be such a thing as the guy that replaced the plugs used plugs from a different year or model that had different wire colors. As long as the wires are going to the correct location on the computer, the computer won't care what color the wires are. The plugs from several different years and body styles can plug into the computers, but the wire colors and harnesses can be body and year specific. Gene

Top
#2413385 - 12/04/17 10:45 PM Re: 2001 Ram Van electrical issue [Re: poorboy]
SALEM1912 Offline
mopar

Registered: 03/09/07
Posts: 514
Loc: Southeast Pa.
What engine and are you looking at the three PCM connectors? Also I may have a shop manual for that year. And it is NOT common for those connectors or wiring to go bad. are there signs of corrosion or physical damage?

Top
#2414775 - 12/07/17 01:46 PM Re: 2001 Ram Van electrical issue [Re: cudaman1969]
cudaman1969 Offline
master

Registered: 01/25/04
Posts: 3862
Loc: fredericksburg,va
I'll try to answer each reply, the 3 connectors are new, never saw the old ones. Engine runs fine after warm up, won't idle up on start, let off the gas it dies. Got the idle comp ordered, maybe that's bad, has a whistle till warm. Going by the dealer to see if they'll make a printout of the wiring diagram ( I'm good friends with the parts department head guy). Got a code about some hose off, looking for that now. If the wires are right I'll go back and solder each then shrink rap them. He had bought a new coil and it was just hanging by the wires, gives you an idea what I'm dealing with.
Thanks for the help
5.9 engine


Edited by cudaman1969 (12/07/17 01:47 PM)

Top
#2414834 - 12/07/17 03:30 PM Re: 2001 Ram Van electrical issue [Re: cudaman1969]
stumpy Offline


Registered: 01/19/03
Posts: 28840
Loc: Grand Prairie,Texas
Cure the whistle which is probably the hose off and the cause of your idle trouble then worry about the wiring.

Top
#2414859 - 12/07/17 04:18 PM Re: 2001 Ram Van electrical issue [Re: cudaman1969]
cudaman1969 Offline
master

Registered: 01/25/04
Posts: 3862
Loc: fredericksburg,va
Throttle body is carboned up?? Shouldn't be right? got to thinking about that bottom pan on intake, leaking? ( maybe the whistle)? Put new battery in, started and ran normal cold. Chasing gremlins!


Edited by cudaman1969 (12/07/17 04:18 PM)

Top

Advertisement
Sponsored Link
Forum Stats
25,078 Registered Members
32 Forums
185,681 Topics
2,158,710 Posts

Most users ever online: 882 @ 03/05/17 10:15 PM
Moparts Newest Topics
Did any of these survive?
by sp392
20 minutes 46 seconds ago
arp rod bolts
by bonefish
Today at 08:12 AM
Seller says worth 50k restored. Better grab it quick
by 67DeLuxe
Today at 01:22 AM
My son's ride in a hemi Dart
by Jim_Lusk
Today at 12:44 AM