Topic Options
#1058655 - 08/21/11 12:37 PM ECU gone bad. What do you guys use?
MoparDonny Offline
top fuel

Registered: 11/05/04
Posts: 1760
Loc: Port Alberni, British Columbia
I know it's been talked about as many times as pinion angle, but..............
My Dad runs the FBO stuff and it works great but I'm still using Mopar stuff, currently Chrome box and Chrome coil. I am going to replace the coil and the Chrome ECU because i had to borrow them from my dads spare parts box at the races last week. My car would hit 6200 and that was it, felt like a rev limiter. I've heard guys having good luck with NAPA stuff but thought I'd ask before buying.
Thanks.
Don.


Attachments
6788308-283429_248127861874348_100000314081965_870864_3465000_n.jpg (107 downloads)

_________________________
'71 451 Challenger 3.91's and 3" X with Spintechs BEST TIMES : 7.349 @ 96.14 ,1.609 60 ft at an airport. 11.71 @ 115.62 1.64 60 ft also at an airport. '04 Ram 1500 HEMI '04 SX 2.0

Top
#1058656 - 08/21/11 12:38 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
CrAzYMoPaRGuY Offline
I Live Here

Registered: 10/06/04
Posts: 16210
Loc: Canada
I think I'm going to try the new FBO stuff on my Charger...
_________________________
CrAzYMoPaRGuY

Top
#1058657 - 08/21/11 12:40 PM Re: ECU gone bad. What do you guys use? [Re: CrAzYMoPaRGuY]
MoparDonny Offline
top fuel

Registered: 11/05/04
Posts: 1760
Loc: Port Alberni, British Columbia
Is the FBO stuff recommended for daily driver use though? I don't make long trips but I drive it a fair bit.
_________________________
'71 451 Challenger 3.91's and 3" X with Spintechs BEST TIMES : 7.349 @ 96.14 ,1.609 60 ft at an airport. 11.71 @ 115.62 1.64 60 ft also at an airport. '04 Ram 1500 HEMI '04 SX 2.0

Top
#1058658 - 08/21/11 12:44 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
CrAzYMoPaRGuY Offline
I Live Here

Registered: 10/06/04
Posts: 16210
Loc: Canada
Quote:

Is the FBO stuff recommended for daily driver use though? I don't make long trips but I drive it a fair bit.




I have the original FBO setup on my Jensen- the A688. I daily drive my Jensen and go out for hours at a time, runs like a clock. It's been running well over a year.

The new setup is supposed to be more powerful, but I haven't tried it yet.... others will have to chime in.
_________________________
CrAzYMoPaRGuY

Top
#1058659 - 08/21/11 02:11 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
MR_P_BODY Online   content
Master

Registered: 06/13/03
Posts: 50922
Loc: Romeo MI
How long have you had that chrome box on it... things
do wear out... my fist ignition was the gold box but
thats not for the street
_________________________

W-9 8.94 @ 151 NOW ON E-85
Mike "Raff"...(180)Watching over us
CAR IS FOR SALE

Top
#1058660 - 08/21/11 04:02 PM Re: ECU gone bad. What do you guys use? [Re: MR_P_BODY]
MoparDonny Offline
top fuel

Registered: 11/05/04
Posts: 1760
Loc: Port Alberni, British Columbia
Quote:

How long have you had that chrome box on it... things
do wear out... my fist ignition was the gold box but
thats not for the street





I'm gonna guess 4 or 5 years max. This might be 5th summer with it. I only put 500 miles a year on the car at most. I had heard someone say before that the boxes NAPA carries seem like good quality
_________________________
'71 451 Challenger 3.91's and 3" X with Spintechs BEST TIMES : 7.349 @ 96.14 ,1.609 60 ft at an airport. 11.71 @ 115.62 1.64 60 ft also at an airport. '04 Ram 1500 HEMI '04 SX 2.0

Top
#1058661 - 08/21/11 04:24 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
MR_P_BODY Online   content
Master

Registered: 06/13/03
Posts: 50922
Loc: Romeo MI
Quote:

Quote:

How long have you had that chrome box on it... things
do wear out... my fist ignition was the gold box but
thats not for the street





I'm gonna guess 4 or 5 years max. This might be 5th summer with it. I only put 500 miles a year on the car at most. I had heard someone say before that the boxes NAPA carries seem like good quality




To me... if its a street car I want something I can
get anywhere to get me home... a race car I use MSD
because most guys use it and I MIGHT be able to
get a part at the track if I have a problem.... I
always look for easy access to stuff like that...
I dont know if NAPA is better or not
_________________________

W-9 8.94 @ 151 NOW ON E-85
Mike "Raff"...(180)Watching over us
CAR IS FOR SALE

Top
#1058662 - 08/21/11 05:50 PM Re: ECU gone bad. What do you guys use? [Re: MR_P_BODY]
J_BODY Offline
I Live Here

Registered: 04/30/03
Posts: 11580
Loc: aZLiViN
Back in my street days I ran a chrome box that started giving me fits, especially when hot. I lengthened the wiring and moved it up to the front of the radiator support. Worked like a champ until I finally went complete MSD as the car had become full time race.

Top
#1058663 - 08/22/11 02:44 PM Re: ECU gone bad. What do you guys use? [Re: J_BODY]
Paul_Fancsali Offline
master

Registered: 01/21/03
Posts: 2926
Factory 4 prong control box or convert to pertronix. I for one only use the Mopar elec for backup ignition All is there except dist which I carry in a tool box

Top
#1058664 - 08/22/11 07:26 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
Sinitro Offline
master

Registered: 01/20/03
Posts: 4985
Loc: So Cal
Before chucking the chrome box..
Be sure to check your ground connections for the box closely, these need to be tite & kleen..

Just my $0.02...

Top
#1058665 - 08/22/11 08:41 PM Re: ECU gone bad. What do you guys use? [Re: Sinitro]
Hot 340 Offline
master

Registered: 12/01/06
Posts: 3181
Loc: Pa
Quote:

Before chucking the chrome box..
Be sure to check your ground connections for the box closely, these need to be tite & kleen..

Just my $0.02...


Some real good advice here ^.. I had a chrome one do that and wasnt grounded well.. also burnt a couple of chrome boxes up using an accell super coil. You might want to consider a stock oe black box, mine never misses a beat, but I dont go past 6700.

Top
#1058666 - 08/22/11 09:06 PM Re: ECU gone bad. What do you guys use? [Re: Hot 340]
toddd Offline
super stock

Registered: 01/21/03
Posts: 999
Loc: British Columbia
Don, I'll double check but I've got a FBO ecu i haven't used...still in the box.

it's your if you want it.

Top
#1058667 - 08/23/11 08:52 PM Re: ECU gone bad. What do you guys use? [Re: toddd]
MoparDonny Offline
top fuel

Registered: 11/05/04
Posts: 1760
Loc: Port Alberni, British Columbia
Todd, you going to McNeill on Friday?? I'll be there late but I'm going right after work. Probably get there around 10PM

Don.


Attachments
6792165-264023_187458234642389_100001346405510_446318_4335049_n.jpg (77 downloads)

_________________________
'71 451 Challenger 3.91's and 3" X with Spintechs BEST TIMES : 7.349 @ 96.14 ,1.609 60 ft at an airport. 11.71 @ 115.62 1.64 60 ft also at an airport. '04 Ram 1500 HEMI '04 SX 2.0

Top
#1058668 - 08/23/11 08:56 PM Re: ECU gone bad. What do you guys use? [Re: Hot 340]
MoparDonny Offline
top fuel

Registered: 11/05/04
Posts: 1760
Loc: Port Alberni, British Columbia
Quote:

I had a chrome one do that and wasnt grounded well.. also burnt a couple of chrome boxes up using an accell super coil. You might want to consider a stock oe black box, mine never misses a beat, but I dont go past 6700.




I never need more than 6500 at absolute most anyway, but it's embarrassing when it pops like a chevy.
_________________________
'71 451 Challenger 3.91's and 3" X with Spintechs BEST TIMES : 7.349 @ 96.14 ,1.609 60 ft at an airport. 11.71 @ 115.62 1.64 60 ft also at an airport. '04 Ram 1500 HEMI '04 SX 2.0

Top
#1058669 - 08/23/11 08:59 PM Re: ECU gone bad. What do you guys use? [Re: MoparDonny]
toddd Offline
super stock

Registered: 01/21/03
Posts: 999
Loc: British Columbia
I'm going to...just waiting for a F****'n t/o bearing, so i can put the car together again....6 times this year so far.

I'll bring it.

Top

Advertisement
Forum Stats
25,488 Registered Members
32 Forums
193,034 Topics
2,253,325 Posts

Most users ever online: 1,424 @ 06/20/18 07:18 PM
Moparts Newest Topics
1986 Buick Grand National - $8900
by Soopernaut
52 minutes 58 seconds ago
CLAYBARS
by Magnumguy
Today at 11:04 AM
Tic Toc Tach ground?
by JMCFAN
Today at 10:49 AM
1970 Plymouth Road Runner Hardtop
by tomsjack
Today at 04:21 AM