Previous Thread
Next Thread
Print Thread
2014 Ram radio stopped working. #2469985
03/21/18 08:50 PM
03/21/18 08:50 PM
Joined: Nov 2003
Posts: 5,040
Indianapolis
D
Dave Watt Offline OP
master
Dave Watt  Offline OP
master
D

Joined: Nov 2003
Posts: 5,040
Indianapolis
I purchased my 2014 Ram Cummins 2500 new in February 2014. It only has 32,400 miles.
It was at the dealership two weeks ago for the water pump recall.
Picked it up and went to the car wash, removed the antenna, the radio stopped working because the antenna was off. After the car wash I reinstalled the antenna but the radio wouldn't come back on. Took it to dealership today and they said the radio is bad. I find it difficult to believe the radio went bad at the exact moment the antenna was removed. This is the 8" UConnect screen.
Has anyone else had this issue?
They also told me that they replace a lot of radios, hmmmmm.

Re: 2014 Ram radio stopped working. [Re: Dave Watt] #2469991
03/21/18 09:04 PM
03/21/18 09:04 PM
Joined: Dec 2016
Posts: 401
Usa
A
A39Coronet Offline
mopar
A39Coronet  Offline
mopar
A

Joined: Dec 2016
Posts: 401
Usa
2013 Ram 2500 Diesel...I've had it since 2014 and probably 3 times I've had the radio screen not turn on. It comes back on after I restart the truck, but I've weary about it. Also the 8" uconnect screen.

Sidenote...did Ram finally come up with a fix for the water pumps? I got the recall notice, but all it said was "we do not have a solution for this issue at this time". Same with the alternator recall...


2015 Tri-State Stock Super Stock Champion
2017 Monster Mopar Pro Winner
2018 Monster Mopar No Box Winner
Re: 2014 Ram radio stopped working. [Re: Dave Watt] #2470096
03/21/18 11:11 PM
03/21/18 11:11 PM
Joined: Nov 2003
Posts: 5,040
Indianapolis
D
Dave Watt Offline OP
master
Dave Watt  Offline OP
master
D

Joined: Nov 2003
Posts: 5,040
Indianapolis
I haven't lost the screen, yet.

The water pumps are now arriving at the dealerships. I would call them to schedule an appointment.

Re: 2014 Ram radio stopped working. [Re: Dave Watt] #2471051
03/23/18 06:13 PM
03/23/18 06:13 PM
Joined: Apr 2007
Posts: 2,358
Calgary, Alberta Canada
a12rag Offline
top fuel
a12rag  Offline
top fuel

Joined: Apr 2007
Posts: 2,358
Calgary, Alberta Canada
On the 2013 Journey I got new . . . picked up from dealer one day, next day was message on screen (8.4"? Uconnect) saying bad disc or something like that . . . took to dealer and they replaced the "telematics" unit (i.e. radio, gps, etc, etc) told me it was a "known issue" on all the large unconnect screens in all the vehicles . . . !!! Had it replaced once more under warranty and was fine . . . if you can get replaced on warranty, do it.

Also, go to unconnect website : https://www.driveuconnect.com/

Can get software updates and map updates . . .

Re: 2014 Ram radio stopped working. [Re: Dave Watt] #2487360
04/24/18 04:31 PM
04/24/18 04:31 PM
Joined: Nov 2003
Posts: 5,040
Indianapolis
D
Dave Watt Offline OP
master
Dave Watt  Offline OP
master
D

Joined: Nov 2003
Posts: 5,040
Indianapolis
They replaced my radio and found out that it was bad also. Replaced it again and everything seems fine.
It looks like Chrysler is going to reimburse me for the deductible and the one hour labor.


Advertisement
Sponsored Link
Moparts Newest Topics
51 Dodge B1 Build
by belv2vert66. 09/21/19 02:12 PM
97 yr old Veteran re-jumps “Bridge Too Far”
by 360view. 09/21/19 01:29 PM
It had a Hemi
by jcc. 09/21/19 01:01 PM
Brake.light on?
by robertop. 09/21/19 12:55 PM
Moparts Recent Posts
Valve cover recommendations
by Jeepmon. 09/21/19 03:45 PM
Engine and Trans Lost & Found
by 727builder. 09/21/19 03:43 PM
VIBRATION AT SPEED
by Magnumguy. 09/21/19 03:31 PM
Big Dummy 727 disassembly question
by CMcAllister. 09/21/19 03:31 PM

Powered by UBB.threads™ PHP Forum Software 7.7.1