Previous Thread
Next Thread
Print Thread
83 W150 shuts off while driving #2317498
06/07/17 03:32 AM
06/07/17 03:32 AM
Joined: Feb 2011
Posts: 440
Marysville, WA
77ProStreet Offline OP
mopar
77ProStreet  Offline OP
mopar

Joined: Feb 2011
Posts: 440
Marysville, WA
My 83 W150 runs beautiful, and haven't had any problems with it, but the other day I was driving for about a half hour and it just shut off. When I went to restart, it felt like it was flooded. I made it to the parts store and swapped out the coil, since it looked suspect. After that it ran great, no problems. So today I took it out and drove it on the freeway and all good till I turned into a friends driveway, it died. It did it 3 more times on the way home, each time I had to hold the pedal down to start like it's flooded. I'm thinking its either the ignition module or the ceramic ballast resister. Thing is they are both pretty new.
Do you guys have any ideas?? I am at a loss on this one

Re: 83 W150 shuts off while driving [Re: 77ProStreet] #2317525
06/07/17 09:02 AM
06/07/17 09:02 AM
Joined: Mar 2010
Posts: 627
MD-USA
D
Dodgeguy101 Offline
mopar
Dodgeguy101  Offline
mopar
D

Joined: Mar 2010
Posts: 627
MD-USA
Not saying this is your problem, just sharing an experience.

I had given my son my 88 W250, 318 TBI, it did the same type deal you are talking about, but it would cut off when he hit a bump, had a lift kit on it. Not all the time, just sometimes. Anyway, he found inside the distributor a condenser, not sure right terminology, but it was rusted thru and grounding to the housing. Replaced it and all was well. Pretty sure that is where it was, been a few years ago.

Truck is still going strong. Best truck I ever owned.

Re: 83 W150 shuts off while driving [Re: 77ProStreet] #2317545
06/07/17 10:44 AM
06/07/17 10:44 AM
Joined: May 2003
Posts: 15,473
Florida
S
scratchnfotraction Offline
I Live Here
scratchnfotraction  Offline
I Live Here
S

Joined: May 2003
Posts: 15,473
Florida
hall cell unit in dist

sure it is not vapor locking? check carb next time to see if dry or flooded before pumping/holding to floor after engine stall.

BR most time works or it does not..but could be over heating?

also look at fuseable link for IGN and see if you see any sings of burnt/melt/soft/swollen wire.

make sure underhood harness ground wire on firewall is good.

Re: 83 W150 shuts off while driving [Re: scratchnfotraction] #2317547
06/07/17 10:47 AM
06/07/17 10:47 AM
Joined: May 2003
Posts: 15,473
Florida
S
scratchnfotraction Offline
I Live Here
scratchnfotraction  Offline
I Live Here
S

Joined: May 2003
Posts: 15,473
Florida
I use a points dist to swap out to see if it still stalls after a couple drives/days. to rule out elct6.dist unit.

install and hook points wire up to neg side of coil and remove elctic dist neg wire from coil.

done this many times to get to home or shop when broke out on the road.

check ecu for good ground or melting from overheating.

Re: 83 W150 shuts off while driving [Re: 77ProStreet] #2318766
06/10/17 01:40 AM
06/10/17 01:40 AM
Joined: Jan 2003
Posts: 27,728
places
7
79powerwagon Offline
Too Many Posts
79powerwagon  Offline
Too Many Posts
7

Joined: Jan 2003
Posts: 27,728
places
My 79 PW, it was the steel fuel line running along the frame. It had just a big enough hole/crack in it to sometimes defeat the vacuum pulling the fuel, but not enough to see anything or smell anything. I discovered in a fit of rage as I started at teh fuel tank removing everything, working my way forward. New lines, never another problem.

I'm curious, how does a coil look suspect? wink

Re: 83 W150 shuts off while driving [Re: 77ProStreet] #2318775
06/10/17 02:04 AM
06/10/17 02:04 AM
Joined: Feb 2011
Posts: 440
Marysville, WA
77ProStreet Offline OP
mopar
77ProStreet  Offline OP
mopar

Joined: Feb 2011
Posts: 440
Marysville, WA
Thanks for the help, I haven't had a chance to look at it again. I do wonder about the fuel line tho, I might have to re think the vapor lock idea.

Re: 83 W150 shuts off while driving [Re: 77ProStreet] #2320938
06/14/17 02:20 AM
06/14/17 02:20 AM
Joined: Jan 2008
Posts: 4,252
Canada
WO23Coronet Offline
master
WO23Coronet  Offline
master

Joined: Jan 2008
Posts: 4,252
Canada
Had an 81 D150 that used to shut off on me, wouldn't start until it cooled down abit, bad pickup coil







Powered by UBB.threads™ PHP Forum Software 7.7.1