Page 1 of 16 1 2 3 15 16 >
Topic Options
#527922 - 11/16/09 10:25 AM Got myself an A100!
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Bought a 1966 A-100. Short (not a 108), no side window, V8 3 speed. Very little rust, but lots of dents and holes
Looking at getting it straightened out, fixing the holes and in paint. Will probably swap in a 360, unsure on the trans.
I need some parts, so I'll be asking some questions. Gotta pick up a manual too.
Here's a picture from the ad, I haven't taken any yet.
So tell me about upgrades, parts sources, and cool fixes!


Attachments
5608645-1020091145.jpg (857 downloads)

_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527923 - 11/16/09 10:51 AM Re: Got myself an A100! [Re: RodStRace]
kick_the_reverb Offline
mopar

Registered: 09/07/07
Posts: 574
Loc: Oceanside, CA
Congrats!
Have fun with it, and as you know, I'll gladly provide any info I have.

Ran
_________________________
"Hey mister, something's wrong with your car, it idles roughly" - number one comment I got in Israel when daily driving a 70 Barracuda with a lopey cam. Currently working on - 1966 Dodge A100 van 318/auto Finally - disc brakes on the front. In the plans - rear disc brakes, B&M 250 blower

Top
#527924 - 11/16/09 02:23 PM Re: Got myself an A100! [Re: kick_the_reverb]
ejtmopar Offline
super street

Registered: 03/02/03
Posts: 1131
Loc: plymouth, NH
Convert it to a 4x4!!


Attachments
5608990-110.JPG (324 downloads)


Top
#527925 - 11/16/09 03:29 PM Re: Got myself an A100! [Re: ejtmopar]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Quote:

Convert it to a 4x4!!




Ha ha
It's already got lift blocks front and rear, I plan on dropping it back down.

I have a line on another steering column (broken shifter).
Will need a rear bumper, unless I go full-on old school and get a plank carved out.
Also need a full set of door lock cylinders, ignition switch (parts store), seats (they have been replaced poorly, good luck!)and all weatherstripping.
A guy left a note on it at the races, and I have talked with him. He gave me more info and contacts.


Attachments
5609071-smallDSCF1424.JPG (320 downloads)



Edited by RodStRace (11/16/09 03:33 PM)
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527926 - 11/20/09 10:57 AM Re: Got myself an A100! [Re: RodStRace]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Finally got it off the trailer, and found out it's already got a 360 in it!
Looks like the original valve covers and intake, and haven't checked the heads yet, but big inches!
Pulled the steering column this morning to swap out for one with a good shifter. Hope that after that and a bit of work on one shift linkage, I'll try to get it running!
Still have the 3 speed manual, couldn't read the rear tag, but hoping for a sure-grip.

I've been talking with a new local Moparts member, and he is willing to help me with the bodywork and paint, so the project is getting started.

How much power and gear is it going to take to get this thing to pull the front wheels? I'd rather go that way than a freeway flyer.
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527927 - 11/20/09 11:17 AM Re: Got myself an A100! [Re: RodStRace]
RUMBLON Offline


Registered: 01/20/03
Posts: 9516
Loc: Weiser Idaho
Very cool, what parts ya need? I will keep my eyes open.

Dave

Top
#527928 - 11/20/09 11:56 AM Re: Got myself an A100! [Re: RUMBLON]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Thanks Dave, I still have to clear out the junk in the back that was no extra charge and take stock of what I need.
I will need window/windshield gaskets, weatherstriping (seems there is a guy here that has them), and some other minor things, but I still need to get it running and get some body work done first. No point bolting on nice stuff just to take it back off.
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527929 - 11/20/09 10:55 PM Re: Got myself an A100! [Re: RodStRace]
kick_the_reverb Offline
mopar

Registered: 09/07/07
Posts: 574
Loc: Oceanside, CA
Nice, already ahead of the game before you started! Glad you got it, and good luck on the body and paint.
Ran
_________________________
"Hey mister, something's wrong with your car, it idles roughly" - number one comment I got in Israel when daily driving a 70 Barracuda with a lopey cam. Currently working on - 1966 Dodge A100 van 318/auto Finally - disc brakes on the front. In the plans - rear disc brakes, B&M 250 blower

Top
#527930 - 11/21/09 04:42 PM Re: Got myself an A100! [Re: kick_the_reverb]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Well, I cleaned out the junk in the back, swept it out and got the steering column back in.
The local vatozone had the ignition switch and lock , so those went in. Swapped out the wrong rear bumper for another set of brackets and a stock beat to heck bumper, along with pulling the gas tank since it's in the way of one of the bumper bolts and full of gas.
Next up was throwing a battery in it, and checking the engine over. The firing order was wrong, and the water was low. Fixed that up, and cranked it. It sounded like one cylinder was low, but no sounds, so I primed it and tried to get it running. The carb wouldn't stop flooding, so I go a can of gas to hook up to the pump and a pair of locking pliers on the fuel line. Then the heater core fitting for the hose fell off, so there was only 1/2 water.
I did get it running, but the carb and the water made it only a short time. The thing shakes like they used the neutral flywheel on the 360, and it has a miss.
So, the new list is
GOOD: The full battery box is there, the wiring seems to work (no smoke) except the turn signals and front clearance lights. I got all the doors to work, except I need to install 3 clips. The used column seems to be good. Most stuff has not been messed with, and all fasteners came out well (no rust is a GOOD thing!). The radiator held water, and overall, the thing seems to respond to TLC.
BAD: master cylinder has fluid, but no pedal. I'll try flushing, but will probably have work to do on top of the planned disc swap.
Quite a few little screws and clips are missing. Motor will get swapped. I kind expected this, but had that this one would at least let me move the thing around while doing body/paint.
Will need to get a 360 flywheel. Any suggestions on this would help. The seats need replacing. A-100 seats and clips aren't cheap. Crank pulley wobbles a bit. The steering column I got had the wiring hacked and the old one had an aftermarket turn signal switch. I'll have to get into the top of the column if I want horn and turn signals.

UGLY: I would not have paid a dime for the rear bumper if I had seen it first. The wiring that has been messed with will need work. The motor mounts were installed by the same guy, and I will need to weld and file at least one of the shift linkage holes (probably the reason the shifter was broken).

I stink like grease and old gas, but I'm pretty happy. Sure it would have been nice to just get it running, but I think it just wants more attention before it will work.
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527931 - 11/22/09 04:42 PM Re: Got myself an A100! [Re: RodStRace]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Well, day 2 went like day one, some good, some bad.

Spent some time pulling the brackets off the old toyota seats to see what I need to get seats back in. I have most of the stuff, just need seats and pins! One adjuster track is missing one of the rollers...

Removed the rest of the doghouse, except the front. More mismatched hardware.
Removed the bent slide out step. Found out it was added (this is a cargo van, not a sportsman or camper.) Flushed out the old brake fluid and bled them, now have brakes!
Took the carb apart and cleaned out all the junk. Freed up the power circuit, made up a missing accel linkage, and blew out the needle and seat.
This carb is junk, but it's better than the 5 others that were in back! None of them are even for this van!
Bypassed the heater and filled the radiator. Started it up and drove it a few hundred feet, until the wheel fell off!
Swapped on another wheel and added lugs to the other Cragar. At least it will move under it's own power. At that point, the front cover decided it had held long enough and spewed warm coolant directly at where I was sitting on the wheelwell.
Removed the seat belts and pressure washed the inside. I can JB weld the front cover to move it around for body/paint, or just bite the bullet and order the flywheel, pull the motor, swap in the other 360, get an intake, carb and clutch and have it running nice. I'm thinking swap, but it will cut into body time and funds. I'll have to talk to the body guy...


MODS can you move this to the project cars section?


Edited by RodStRace (11/23/09 09:28 AM)
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527932 - 11/23/09 12:16 PM Re: Got myself an A100! [Re: RodStRace]
BloFish Offline


Registered: 11/20/04
Posts: 12194
Loc: In your rear view mirror.
Congrats on your purchase, and welcome to the club

As far as the rear bumper goes, just register it as a commercial vehicle and call it good


Attachments
5622484-tmpphp8dDiGz.jpg (237 downloads)

_________________________
It doesn't really matter whether you win or loose...
as long as you look good doing it!

'65 A100 Panel Van
'69 Barracuda Fastback
'06 Mega Cab 2500 Deisel
'06 Mercedes-Benz SLK 350

Top
#527933 - 11/23/09 12:56 PM Re: Got myself an A100! [Re: RodStRace]
stubbs300 Offline
Vacation

Registered: 07/12/05
Posts: 1181
Loc: Lost in the ozone again
I want to follow tabs on your project as I have a 69 also. They kinda butchered the wiring but does work, if you go with a aft. market wiring kit, I'd be interested who/what you use. Same goes for the brakes, mine are fine but have kicked the idea of disc. I know that MCG last Jan. or Feb had a article on disc swaps for these but still tring o locate a copy. Good luck and enjoy it. I just love the turning radius on these!

Top
#527934 - 11/23/09 01:47 PM Re: Got myself an A100! [Re: stubbs300 ]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
The previous owners didn't hack the wiring too much, so I think I'll be able to put that right.
They added funky lights on the rear, removed the steering column wiring and installed an aftermarket turn signal switch and added, then removed a radio. Luckily, no hacked up doors for speakers. There are a few loose wires here and there that I need to track down too.
The doghouse wiring is stiff and I'd like to replace it, but I want a factory look and I haven't found anyone doing them yet.
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527935 - 11/23/09 02:47 PM Re: Got myself an A100! [Re: RodStRace]
stubbs300 Offline
Vacation

Registered: 07/12/05
Posts: 1181
Loc: Lost in the ozone again
Quote:

The doghouse wiring is stiff and I'd like to replace it, but I want a factory look and I haven't found anyone doing them yet.



Yea that's my problem too, and good luck for us finding something stock looking for these things as I've been looking and comming up empty. May just have to suck it up and go with something different, as I know I'm sure not going to make my own for it!

Top
#527936 - 11/24/09 08:07 AM Re: Got myself an A100! [Re: stubbs300 ]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
I put clips in the door linkage, so now all doors work properly. Didn't have the correct one for the passenger front, but the E clip works okay.
Also dropped off one Cragar and lug nut at the local tire place to get a new set that fits. It will get the Cragars for now, until I can find something I like better. Also installed the RF headlight straight. I just don't understand how people can take something that is keyed to be idiot-proof and still mess it up. There was an inch of fine dust behind the pie pan, the same in both front doors. The more I look, the more dents and holes there are. I'm going to be busy!!!
Still contemplating colors.
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527937 - 11/24/09 09:56 AM Re: Got myself an A100! [Re: stubbs300 ]
3604speed Offline
member

Registered: 07/29/07
Posts: 53
Loc: New Mexico
January / February issue date or the month the mag was delivered?

I will look through my pile for the article.

Top
#527938 - 11/24/09 01:29 PM Re: Got myself an A100! [Re: 3604speed]
RodStRace Offline
I Live Here

Registered: 09/21/05
Posts: 12252
Loc: Chino Valley
Just relating info I have seen, but http://www.aajbrakes.com/ is supposed to have a kit, there is a plate pattern on the Yahoo site for a swap, and http://www.rustyhope.com/home.html
posted a while ago that he has done them and may be able to do another.
It seems that all of these use the 11" spindle, not the 10".
_________________________
Gotta get one of them new Challengers! Rod=1940 Plymouth 5.2L/518 ST=1947 Chrysler Windsor Race=1971 Cuda Daily driver=closest to High Impact available in '04.

Top
#527939 - 11/25/09 03:21 PM Re: Got myself an A100! [Re: 3604speed]
stubbs300 Offline
Vacation

Registered: 07/12/05
Posts: 1181
Loc: Lost in the ozone again
Quote:

January / February issue date or the month the mag was delivered?

I will look through my pile for the article.



Issue date!

Top
#527940 - 11/29/09 10:34 AM Re: Got myself an A100! [Re: stubbs300 ]
kick_the_reverb Offline
mopar

Registered: 09/07/07
Posts: 574
Loc: Oceanside, CA
Hey, I just discovered this new forum, now I know where your post has gone.

There are a few more disc brake options:
Scarebird has already got a 10" spindle (2200 lbs capacity front axle) disc brake kit, and he is making me a 11" spindle (2500 lbs capacity front axle) kit. I'll post when available.

ECI has a kit for the 10" spindle.
Basically any kit that fits mid 60's B bodies should fit the 10" spindle.

There are a couple of members on the Yahoo group that made brackets. I have a setup for the 11" spindle, but decided in the end not to use it because it required trimming the spindle, which I didn't want to do.

Ran
_________________________
"Hey mister, something's wrong with your car, it idles roughly" - number one comment I got in Israel when daily driving a 70 Barracuda with a lopey cam. Currently working on - 1966 Dodge A100 van 318/auto Finally - disc brakes on the front. In the plans - rear disc brakes, B&M 250 blower

Top
#527941 - 11/29/09 11:05 AM Re: Got myself an A100! [Re: kick_the_reverb]
UCUDANT Offline
master

Registered: 01/20/03
Posts: 6717
Loc: New Mexico
Just a thought here, you said you "Will need to get a 360 flywheel." Do to vibration and later stated that "Crank pulley wobbles a bit." Do you mean the vibration dampener? Is it possible that the vibration dampener is bad and causing the issue?

Top
Page 1 of 16 1 2 3 15 16 >