69 B Body carb. spring ?

Posted by: 5carguy

69 B Body carb. spring ? - 02/07/18 06:20 PM

Is this the right carb spring for a 69 Coronet R/T 4 speed.Having a hard time going back to idle at 650.It will stay at 850 unless I pull it back.Fresh build.
Posted by: BlueRacer69

Re: 69 B Body carb. spring ? - 02/07/18 07:30 PM

I think that is the 1968 spring. The 69 spring is gray in color. If I'm wrong I'm sure others will chime-in and correct me. up
Posted by: topside

Re: 69 B Body carb. spring ? - 02/07/18 08:48 PM

As I recall, they were dark green with a dark red stripe, both years.
Try loosening the carb and moving it around a little, butterflies may be catching the gasket or intake. If the spring needs more tension, shorten it a little bit. I also like a 2nd spring as backup, unless correctness is more important.
Posted by: calrobb2000

Re: 69 B Body carb. spring ? - 02/08/18 12:46 AM

hi
your prob may be a gummy throttle cable if it is not a new one ?

remove cable from car and flush it good with brake cleaner to free it .

re install it dry do not lube it traps dirt and becomes sticky !
Posted by: Sinitro

Re: 69 B Body carb. spring ? - 02/08/18 01:39 AM

EZ to check..
Disconnect throttle cable, and now check throttle action..
Does the idle return back down?

Just my $0.02.. wink
Posted by: 5carguy

Re: 69 B Body carb. spring ? - 02/08/18 05:12 PM

I will check the carb gasket,it was a bit tight.The throttle cable is smooth.The spring doesn't seem to be strong enough.Could the vacuum advance be sticking?Just a thought.Thanks for all of the replies.
Posted by: B5 Bee

Re: 69 B Body carb. spring ? - 02/08/18 05:46 PM

Spring attachment is in wrong position, should be on other side of carb linkage.
Not sure what color spring is used for the throttle return but the green spring looks to be the for the trans kick down linkage.
Posted by: rarefish

Re: 69 B Body carb. spring ? - 02/09/18 11:16 AM

Here is a engine shot of my unrestored 68 Charger R/T
Posted by: JohnRR

Re: 69 B Body carb. spring ? - 02/09/18 01:40 PM

Though the spring is in the wrong position I think the problem is the spring itself , a little too long or not the right specs to pull the throttle fully closed?

ASSuMEing the butterflies are not hitting anything ?