Topic Options
#2457740 - 02/26/18 01:10 AM 89 W100 truck stumbles and pops/cracks wont run right
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
Got this truck about a year now, ran fine no problems. running it every week lately. last week it started to stutter, hesitate and almost backfire under power and wont make power or shuts off. What could it be? truck has 89,000 miles. Throttle position sensor? idle sensor? anything else throttle body related? it idles but you can hear it not ideling correct anymore. Mostly when truck is warm or hot is when problem is bad, it stalls. if cold does not do it as quickly.


wizard
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2457760 - 02/26/18 05:17 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
basketcase Offline
master

Registered: 09/03/03
Posts: 7021
Loc: east side of Ohio
I had an '89 act like that and it turned out to be the fuel pump.
_________________________
Dave


1969 Plymouth road runner post 383 4 speed F8
1981 Dodge D150 360 auto

Top
#2457769 - 02/26/18 07:02 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
jerseybud Offline
mopar

Registered: 04/25/04
Posts: 647
Loc: Maine
check your fuel pressure for sure #1. Runs richer when cold so it runs (seems to) better. Supposed to be 14.5 plus minus 1.

Top
#2457775 - 02/26/18 07:37 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: basketcase]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
Brand new fuel pump installed about 4 months ago.
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2457779 - 02/26/18 07:56 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
buildanother Offline
I Live Here

Registered: 08/30/05
Posts: 11293
Loc: chicagoland,usa
You did the filter too right?

Top
#2457789 - 02/26/18 08:18 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
bbtrux Offline
super stock

Registered: 05/03/04
Posts: 942
Loc: ohio
My dollar says distributor. Had an 87 dakota that the hall effect wheel got loose in its plastic retainer. All kind of whacky problems.

Top
#2457790 - 02/26/18 08:18 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: buildanother]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
yes, replaced filter. Seems like this only acts up when truck is warm or has been running for awhile.


Edited by Wizard (02/26/18 08:19 AM)
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2457890 - 02/26/18 11:58 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
jerseybud Offline
mopar

Registered: 04/25/04
Posts: 647
Loc: Maine
Unfortunately, the new aftermarket pumps are on the junky side. If it was an airtex or similar, pump in still very high on list. Then check for codes. Then check for ignition health and distributor shaft wear.

Top
#2457991 - 02/26/18 03:30 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: jerseybud]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
Okay, see if I can limp it into Autobone to check for codes
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2458017 - 02/26/18 04:24 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
basketcase Offline
master

Registered: 09/03/03
Posts: 7021
Loc: east side of Ohio
Originally Posted By Wizard
Brand new fuel pump installed about 4 months ago.


I had a new pump put in mine....lasted a couple months then acted up again. swapped out a used tank and pump and never looked back.
_________________________
Dave


1969 Plymouth road runner post 383 4 speed F8
1981 Dodge D150 360 auto

Top
#2460560 - 03/03/18 02:47 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: bbtrux]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
What do you do to fix this distributor problem if it is what it is? Have not taken to Autobone yet for code reading. Replace whole distributor or is there a part you can replace?
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2461030 - 03/04/18 03:56 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
BIGHOOK Offline
super stock

Registered: 09/10/07
Posts: 1024
Loc: Fitchburg, WI
Replace the Hall effect pickup plate/coil in the distributor. $20-30. Napa or Rock Auto should have it.

A few years back, had an 88 Ramcharger 4x4, 318 TBI. 70k miles. Same problem. Would just stall after driving, fully warmed up. Sometimes right on the freeway in the middle of traffic! Annoying as hell. Replaced the fuel pump, fuel filter, problem continued. Wait about 15-20 min. after stall then restarts no problem and resume driving. Won't throw any codes. Stumped, I spoke with a Chrysler Tech about it. He said the pick-up coil gets hot and shuts off. Common problem. As I recall, at the time, the dealer parts dept always kept an inventory of those coil pickups on hand. Go figure!

Top
#2461043 - 03/04/18 04:23 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: BIGHOOK]
buildanother Offline
I Live Here

Registered: 08/30/05
Posts: 11293
Loc: chicagoland,usa
Seen them fail hot here too. Normally, they would not do the intermit misfire, they would heat up and quit like you said. And when the codes come up, I think 12 and 37 are no prob normal.

Top
#2461124 - 03/04/18 05:47 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
BIGHOOK Offline
super stock

Registered: 09/10/07
Posts: 1024
Loc: Fitchburg, WI
Right. I don't know if this problem would come up on lower mile, newer TBI's but the pick-up coil failure would rear it's ugly head on higher mileage TBI Rams of the ones I've encountered, around 60k and up. The Ramcharger had 130k when I sold it. The problem never occured again 60k later after I replaced it. I did give the buyer a spare pick-up just in case...

Top
#2466296 - 03/14/18 09:51 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: BIGHOOK]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
Okay, will keep this on the lists of fixs. Been getting a few different theorys of what is wrong. Will have to try it. What about Map sensor? Someone mentioned that
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2478011 - 04/05/18 05:48 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
Well, think may have eliminated few things about what is causing this problem.

Don't think its fuel pump as I plowed the driveway full of snow 2 weeks ago. Ran fine for 1/2 hour. Then noticed it was just starting its problem a little bit when I was done plowing. Started to stumble and not run right. I don't think its the fuel pump.


We replaced the throttle position sensor last week, today was the test for it. Ran down town to post office ran okay. Then after about 25 minutes of running it started to act up, hesitant, coughs, not running right. Turned it off for little over an hour and then starts up okay and runs.

Come to conclusion it is acting up when it gets hot or running for about 1/2 hour. Heat related problem.

Could this be worn out o2 sensor?
Clogged cat? Bad Map sensor? I am thinking of trying o2 sensor first.
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2479549 - 04/08/18 04:25 PM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
Wizard Offline
mopar

Registered: 02/17/07
Posts: 641
Loc: Dillsburg, PA
I could not get the oxygen sensor busted loose so I put on the new MAP sensor on. This fixed the truck and not having anymore problems. Still going to put the oxygen sensor on, just have to bust it loose somehow to get new sensor on. Truck has 82,000 miles on it. Sensor needs replaced anyhows.

Wizard
_________________________
Guns, God, and Country. U.S. Veteran

Top
#2506238 - 06/09/18 11:14 AM Re: 89 W100 truck stumbles and pops/cracks wont run right [Re: Wizard]
JDMopar Offline
master

Registered: 01/19/03
Posts: 7885
Loc: Candler,NC / Myrtle Beach, SC
Is your truck still running ok after the fix? I have an 88 TBI truck that is doing the same thing. If I looked at it right....the MAP sensor is on the passenger side of the firewall. They're proud of those things at the parts house! eek
_________________________

Top

Advertisement
Forum Stats
25,636 Registered Members
32 Forums
195,709 Topics
2,289,786 Posts

Most users ever online: 1,424 @ 06/20/18 07:18 PM
Moparts Newest Topics
'71 B-body: tips on routing wire for rear deck speakers?
by Fab64
5 minutes 30 seconds ago
A-body console carpet pics
by njmopar
Today at 10:55 AM
’67 Newport Drives Against Parkinson’s Disease
by Rustymuscle
Today at 10:52 AM
Real 1970 hemicuda convertible for sale
by biggE
Today at 10:51 AM