Page 3 of 3 < 1 2 3
Topic Options
#2420427 - 12/18/17 02:19 PM Re: Broke my K Frame [Re: Frankenduster]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Ok, so got it out. I think the pictures below explain it all. I think my repair job will hold up just fine, let me know what you think.


Attachments
IMG_4876.jpg

Description: I think this is supposed to be attached.

IMG_4884.jpg

Description: Everyone knows black duct tape is superior to the standard silver tape, so I think I got this covered.

IMG_4882.jpg

Description: Best part about it, it blends right in, so I don't even have to repaint!


_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2420431 - 12/18/17 02:28 PM Re: Broke my K Frame [Re: mickm]
Fat_Mike Offline
mopar

Registered: 05/08/03
Posts: 658
Loc: N.W. Florida
Originally Posted By mickm
Ok, so got it out. I think the pictures below explain it all. I think my repair job will hold up just fine, let me know what you think.


Nice job, Mick! Personally, I would have used a generous bead of super glue prior to applying the duct tape. But that might be overkill...

Top
#2420434 - 12/18/17 02:29 PM Re: Broke my K Frame [Re: mickm]
krautrock Offline
top fuel

Registered: 01/27/03
Posts: 1763
Loc: central texas
is there something weird going on with your LCA pivot tube? the weld looks strange.

Top
#2420497 - 12/18/17 03:37 PM Re: Broke my K Frame [Re: krautrock]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Originally Posted By krautrock
is there something weird going on with your LCA pivot tube? the weld looks strange.


Yes, I noticed that as well. We will be going over the whole k frame, looking for any other issues, so I'll definitely take a closer look at that.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2420499 - 12/18/17 03:38 PM Re: Broke my K Frame [Re: Fat_Mike]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Originally Posted By Fat_Mike
Originally Posted By mickm
Ok, so got it out. I think the pictures below explain it all. I think my repair job will hold up just fine, let me know what you think.


Nice job, Mick! Personally, I would have used a generous bead of super glue prior to applying the duct tape. But that might be overkill...


Yeah, I think so. The engine only puts out 700hp, duct tape should handle that! up
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2420501 - 12/18/17 03:38 PM Re: Broke my K Frame [Re: mickm]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
But seriously folks, ee are going to repair it. It is truly amazing, just how bad these welds were from the factory and that it lasted this long. I thought about which way to go, and with the above fact, terrible welds and still it lasting as long as it did, I don't have any doubts that welded properly it will be good from here on out. We are going to go over the rest of the k frame and redo welds that don't look good as well.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2420720 - 12/18/17 09:36 PM Re: Broke my K Frame [Re: mickm]
Jim_Lusk Offline
I Live Here

Registered: 03/18/03
Posts: 17381
Loc: Fresno, CA
From what I can tell the welder missed most of the mount perch. I picked up an A-body k-member where they forgot to weld in one of the strut rod reinforcement plates. The body of the k-member cracked behind it.

Top
#2420761 - 12/18/17 10:46 PM Re: Broke my K Frame [Re: Jim_Lusk]
RUNCHARGER Offline
I Live Here

Registered: 01/20/03
Posts: 15695
Loc: Chilliwack B.C. Canada
I've seen messed up control arm tubes before, they can be tricky to weld.
_________________________
Sheldon

Top
#2421278 - 12/19/17 10:41 PM Re: Broke my K Frame [Re: RUNCHARGER]
Jim_Lusk Offline
I Live Here

Registered: 03/18/03
Posts: 17381
Loc: Fresno, CA
Originally Posted By RUNCHARGER
I've seen messed up control arm tubes before, they can be tricky to weld.


The last few k-members that I have done I have cut the bottom open below the pin tubes and welded from the inside. Might also make sense to open the top and weld it from the top, too.

Top
#2421939 - 12/21/17 02:46 PM Re: Broke my K Frame [Re: Jim_Lusk]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Originally Posted By Jim_Lusk
Originally Posted By RUNCHARGER
I've seen messed up control arm tubes before, they can be tricky to weld.


The last few k-members that I have done I have cut the bottom open below the pin tubes and welded from the inside. Might also make sense to open the top and weld it from the top, too.


I'm hoping it doesn't come to that. If so, may be worth just finding another one. I'm hoping to have it back from the powder coating guys, (burning the old stuff off), soon, and then we can really go over it.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2422170 - 12/21/17 10:45 PM Re: Broke my K Frame [Re: mickm]
Jim_Lusk Offline
I Live Here

Registered: 03/18/03
Posts: 17381
Loc: Fresno, CA
I do it as a preventative measure. I'm not sure about your k-member, but the tubes did not receive much of a weld on one end on A-bodies. Here's a pic. I actually split this K-member so that I could straighten it. In part just to see if I could...


Attachments
DW213185.JPG



Top
#2422327 - 12/22/17 12:23 PM Re: Broke my K Frame [Re: RUNCHARGER]
jbc426 Offline
master

Registered: 03/01/07
Posts: 2787
Loc: West Coast, USA
That car is a beast! Does it already have subframe connectors in it and the front frame rails tied together?
_________________________
1970 Plymouth 'Cuda #'s 440-6(block in storage)currently 493" 6 pack, Shaker, 5 speed Passon, 3.73s
1968 Plymouth Barracuda Convertible 408 Magnum EFI with 4 speed automatic overdrive, 3800 stall lock-up converter and 3.91's (closest thing to an automatic 5 speed going)

Top
#2422346 - 12/22/17 01:28 PM Re: Broke my K Frame [Re: jbc426]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Originally Posted By jbc426
That car is a beast! Does it already have subframe connectors in it and the front frame rails tied together?


I have the US Cartool connectors, the ones that are welded all along the bottom of the floorpan. It makes a big difference!
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2428161 - 01/03/18 01:02 AM Re: Broke my K Frame [Re: mickm]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
So, here is the latest. The K frame is all welded up and ready to go. We tacked the perch on, and then I did a test fit, and it was perfect, so we finished off the welding.

I decided to stick with this (instead of going for a MegaParts hemi K frame, I have the Schumacher mounts), for the following reason. When you look at the photos, you will see how ungodly horrific the welds that held this perch on were. It's absolutely astonishing to me that as bad as these welds were, that the thing lasted this long. The welds along the seams that make the perch itself are very, very nice welds, so no worry at all there. When you compare what was there before, and what is there now, I have full confidence that it will outlive me!

I also put the FirmFeel braces on the LCA's, a few pictures of those.

We also reinforced a number of other areas on the K frame. Some welds I ground away and we redid, and some we just added in places that can only help. Pictures should say everything.


Attachments
IMG_4889.jpg

Description: This is where the perch was welded on the top. You can see that the weld barely penetrated the metal of the perch.

IMG_4890.jpg

Description: This is along the side. Again, astonishing these held as long as they did.

IMG_4891.jpg

Description: A zoomed out shot.

IMG_4904.jpg

Description: Control arm with FirmFeel brace.


_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2428163 - 01/03/18 01:06 AM Re: Broke my K Frame [Re: mickm]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
More pics:


Attachments
IMG_4910.jpg

Description: The top of the steering box mount. This is from the factory, (minus my cleaning it up).

IMG_4913.jpg

Description: Whoops! A split in the metal. Don't know if that has been there, or was caused by the latest incident.

IMG_4914.jpg

Description: The perch, with new welds.

IMG_4916.jpg


_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2428164 - 01/03/18 01:08 AM Re: Broke my K Frame [Re: mickm]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
And the last few:


Attachments
IMG_4918.jpg

Description: A few additional welds.

IMG_4920.jpg

Description: The mess on top of the steering box mount cleaned up.

IMG_4925.jpg

Description: The split welded up.


_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2428244 - 01/03/18 09:52 AM Re: Broke my K Frame [Re: mickm]
VL21 Offline
pro stock

Registered: 12/14/07
Posts: 1221
Loc: central Florida

WOW, some of those factory welds look like my doing!

But, I swear, I was nowhere near the the factory back then, Iowa at the time, in college.

Sooo, my welds WOULD have looked like that ...
_________________________
It takes gasoline to interest me.

Top
#2428278 - 01/03/18 11:00 AM Re: Broke my K Frame [Re: VL21]
mickm Offline
master

Registered: 07/26/06
Posts: 4080
Loc: California
Originally Posted By VL21

WOW, some of those factory welds look like my doing!

But, I swear, I was nowhere near the the factory back then, Iowa at the time, in college.

Sooo, my welds WOULD have looked like that ...


It is scary how bad some of them were. Especially that perch. The guy knew that this was holding the engine in place, but hey, good enough, I guess...

I didn't show any pictures of the before on some of the others, but pretty bad. Hard to believe someone was hired with that lack of a skillset.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2428499 - 01/03/18 06:30 PM Re: Broke my K Frame [Re: mickm]
pittsburghracer Offline
Slowride

Registered: 02/02/05
Posts: 13445
Loc: PA.
That looks much better. Great job
_________________________
1970 Duster
Edelbrock headed 408
6.143@110.89 mph
9.73@135.05 mph shifting at 6700 RPM
422 Indy headed small block
6.001@113.27mph
9.42@138.27

Untitled by John Cadamore, on Flickr





Top
#2428516 - 01/03/18 06:51 PM Re: Broke my K Frame [Re: mickm]
Jim_Lusk Offline
I Live Here

Registered: 03/18/03
Posts: 17381
Loc: Fresno, CA
I've seen more sloppy welds on k-members than on about anything else.

Top
Page 3 of 3 < 1 2 3

Advertisement
Forum Stats
25,531 Registered Members
32 Forums
193,937 Topics
2,265,073 Posts

Most users ever online: 1,424 @ 06/20/18 07:18 PM
Moparts Newest Topics
1962 B body brake booster questions
by JTECDN
Today at 12:28 AM
440 stroker?
by Nick Stevanovski
Yesterday at 11:13 PM
Question for the grillling masters on here
by MidPenMopar
Yesterday at 11:10 PM
late 70's Truck carpet
by Uberpube
Yesterday at 09:36 PM