Topic Options
#2413748 - 12/05/17 04:18 PM 1983 Lean Burn
Redbaron314 Offline
member

Registered: 12/05/17
Posts: 3
Loc: Michigan
I have a 1983 Chrysler Cordoba with a 318 lean burn 2bbl. I am not looking to delete it just yet so I am trying to troubleshoot and repair at the moment. So when I am trying to drive the car I have to barley press on the pedal or it falls flat on it nose and what sounds like pops through the carb. it has a Complete tune up recently done, timing verified with a timing light, new fuel filter and pump.

Top
#2413793 - 12/05/17 05:18 PM Re: 1983 Lean Burn [Re: Redbaron314]
Diplomat360 Offline
pro stock

Registered: 01/20/03
Posts: 1203
Loc: Windsor, ON, Canada
Man, that's a tough one...it's been years now since I've worked with the LB stuff, but with the car parked (shift selector in P or N) and timing light hooked up, what happens to the timing when you take it off idle???

The LB computer is programmed to control the timing once the carb comes off idle setting. I am thinking of this simple test as a way to at least determine if the LB computer is the problem, or maybe something else?

If the timing jumps (could advance, or it could retard) then the LB box is probably not the culprit, because the change in timing would indicate the LB ECU is reacting to the change...mind you, it could of course be reacting incorrectly...grrhh....
_________________________
1980 Dodge Diplomat Coupe, 360-4bbl, 727, 3.91 SG motivated sleeper! 1981 Dodge Diplomat Coupe, /6 38K mi. survivor car, awaiting restoration.

Top
#2413796 - 12/05/17 05:22 PM Re: 1983 Lean Burn [Re: Redbaron314]
Θάνατος Offline
supercuda

Registered: 09/04/07
Posts: 12836
Loc: betwixt the land of the living...
Sounds like the accelerator pump in the carb is bad. I'd check that before I got all worked up about the LB.

Top
#2413822 - 12/05/17 06:02 PM Re: 1983 Lean Burn [Re: Redbaron314]
Redbaron314 Offline
member

Registered: 12/05/17
Posts: 3
Loc: Michigan
Ok, thank you for the advice on my tricky situation. Now I have been hearing all over just buy the lean burn delete kit and so far before I remove all my hair that might be the best option. Problem being I cannot find this kit......

Top
#2413824 - 12/05/17 06:05 PM Re: 1983 Lean Burn [Re: Redbaron314]
Θάνατος Offline
supercuda

Registered: 09/04/07
Posts: 12836
Loc: betwixt the land of the living...
There is no kit, per se.

You replace the carb with a non-lean burn one and put an electronic ignition conversion kit in

http://www.manciniracing.com/ma27331834033.html

Top
#2413830 - 12/05/17 06:15 PM Re: 1983 Lean Burn [Re: Θάνατος]
DarrenS Offline


Registered: 05/06/04
Posts: 565
Loc: Courtenay, B.C.
Originally Posted By Supercuda
Sounds like the accelerator pump in the carb is bad. I'd check that before I got all worked up about the LB.


I'd agree not to get worked up. Most problems I've had with lb cars have been attributable to the standard stuff (vacuum leaks and carb or ignition problems).

I would not just swap it all out unless you wanted to start upgrading everything for performance...

Top
#2413835 - 12/05/17 06:30 PM Re: 1983 Lean Burn [Re: DarrenS]
RapidRobert Offline
Circle Track

Registered: 11/20/03
Posts: 33030
Loc: Lincoln Nebraska
What Supercuda & Darren said, check the squirt for immediate tip in/quantity then if good I would search for a vac leak.
_________________________
live every 24 hour block of time like it's your last day on earth

Top
#2413846 - 12/05/17 06:54 PM Re: 1983 Lean Burn [Re: Redbaron314]
Redbaron314 Offline
member

Registered: 12/05/17
Posts: 3
Loc: Michigan
ok, and ty for the lb delete info also

Top
#2416183 - 12/10/17 11:24 AM Re: 1983 Lean Burn [Re: Redbaron314]
DynoDave Offline
master

Registered: 01/20/03
Posts: 3002
Loc: MICHIGAN
Certainly have to check the basics, like accelerator pump shot, before moving on.

I'm not as familiar with the later system...have worked on '77 and '78 models. But they used a ground wire on the throttle stop so the system knows when the throttle is closed. Also, they have a throttle position transducer (TPS in modern terms). If accelerator pump action seems good, checking the condition of these may help. The computer can't react if it doesn't know the throttle is moving.

If you have a set of '83 factory service manuals, they're sure to be of help. If you don't have a set, and get stuck, let me know. I have a set, and can check through the diagnostics for you, post some photos of those pages, etc.
_________________________
DynoDave
WPC #12304
1970 Plymouth Duster
1972 Dodge Charger Rallye
1977 Chrysler Cordoba
http://wichargerguy.proboards.com/



Top
#2417165 - 12/11/17 11:52 PM Re: 1983 Lean Burn [Re: Redbaron314]
Diplomat360 Offline
pro stock

Registered: 01/20/03
Posts: 1203
Loc: Windsor, ON, Canada
Given the OP's comment below:

Originally Posted By Redbaron314
...it has a Complete tune up recently done, timing verified with a timing light, new fuel filter and pump...

...I honestly can not even imagine such a tune-up not covering something as basic as Carb 101: is the accel pump working? is it providing good enough volume of fuel? etc, etc.

But anyways...so my feedback is based on personal experience with different LB computers, specifically the timing differences programmed in on a 2 bbl vs 4 bbl setup.

In my case (many many years ago, so memory is a little faint) I picked up a 4 bbl setup at a swap meet. Given that I just installed my first 4 bbl carb (Carter TQ) I thought this would have been a great improvement. Well, something was probably wrong with that LB module because that very night I took the car out I had a massive backfire after a WOT run which literally blew off the muffler...LOL, yeah, impressed all my buddies, but gave me a busted exhaust pipe.

Sooo...off I went digging into the specs and all that, eventually found out that the 4 bbl unit did have a different timing amount (initial, off-throttle and vac-advance) that would have been the right move for my setup had it worked correctly. Who's to tell if I simply missed an additional input of some sorts though...I studied that darn hook-ups, but was just cutting my "teeth" on LB era Mopars at the same time.

Anyways, like I said, for what it's worth given my hands-on experience.

Top
#2417217 - 12/12/17 05:11 AM Re: 1983 Lean Burn [Re: Redbaron314]
rumblebee4232 Offline


Registered: 12/22/13
Posts: 185
Loc: Stinnett, Tx
Did the car sit for a while?? Is the fuel old?? I had one that acted like you are describing(not lean burn) and it turned out that there was water in the carburetor.. cleaned it out and it ran like new again..

Top

Advertisement
Sponsored Link
Forum Stats
25,083 Registered Members
32 Forums
185,758 Topics
2,159,787 Posts

Most users ever online: 882 @ 03/05/17 10:15 PM
Moparts Newest Topics
dash pad restoration?
by fuelishnsilly
01/23/18 01:49 AM
Factory sunroof question
by FuryRoad
01/22/18 10:50 PM
63 Sport Fury Goldencommando emblem placement
by GOLDENCOMMANDO
01/22/18 10:40 PM
73-74 B-Body Odometer
by 340cpe
01/22/18 10:27 PM