Page 1 of 3 1 2 3 >
Topic Options
#2405773 - 11/18/17 11:02 PM Broke my K Frame
mickm Offline
master

Registered: 07/26/06
Posts: 4073
Loc: California
So the perch that the engine mount bolts to on the K Frame is completely broken on the passenger side. It has slid about an inch and a half away from it's original position, and it's pretty obvious to see the engine leaning way to the left.

Think this is possible to repair in the car? Lift the engine as far out of the way as possible, weld this thing back on?

Doesn't seem feasible to me, although a friend suggested it.

Pretty bummed out about this at the moment, but I guess as hard as I drive this car, it isn't unexpected.

If I have to take it out, is it reasonable to just hoist the engine out of the way, or do I really need to pull the engine and trans?


Edited by mickm (11/18/17 11:15 PM)
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2405783 - 11/18/17 11:33 PM Re: Broke my K Frame [Re: mickm]
Jim_Lusk Offline
I Live Here

Registered: 03/18/03
Posts: 17326
Loc: Fresno, CA
Support the engine and pull the k-member out. I have done many k-member repairs, but haven't encountered this issue before. I don't see where it would be that difficult, though. A bare block with the mounts attached should work to get it back. It might also be obvious where it goes...

Top
#2405788 - 11/18/17 11:42 PM Re: Broke my K Frame [Re: mickm]
Sixpak Offline
master

Registered: 01/20/03
Posts: 6222
Loc: The Swamp
Is it a clean break or has it chewed up the crack some? Can you get it clean enough and prepped in the car to weld in the car? Any issues getting the mig torch head in there and will it be a difficult weld in terms of the position? If it is possible to weld in the car I'd remove any ignition boxes, and voltage regulators or other electronics in the car lest the weld current damage them. I fried a voltage regulator on a mower welding up a part with a mig welder.

Top
#2405796 - 11/19/17 12:14 AM Re: Broke my K Frame [Re: mickm]
71birdJ68 Offline
master

Registered: 02/09/12
Posts: 3875
Loc: Morristown Tn.
I would say pull it, and send to Mega Parts, I think they have a jig, and then it would be done right. They

Top
#2405801 - 11/19/17 12:44 AM Re: Broke my K Frame [Re: mickm]
Frankenduster Offline
Moparts proctologist

Registered: 02/15/10
Posts: 15242
Loc: Granite Bay CA
Or send it to Firm Feel. While there, they can weld in their reinforcement bracing kit.
Is this the 383 K member or a genuine HEMI K member?

Top
#2405821 - 11/19/17 02:15 AM Re: Broke my K Frame [Re: Frankenduster]
mickm Offline
master

Registered: 07/26/06
Posts: 4073
Loc: California
I haven't had a good view of exactly what it looks like yet. It is the 383 K Member, not the hemi one. I think once I have it out it will be very obvious how it all goes back together, I just can't imagine doing a proper job of it while it is still in the car.

I just have to come up with a good way to support the engine, and then the rest is just dropping it out.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2405825 - 11/19/17 03:36 AM Re: Broke my K Frame [Re: mickm]
Frankenduster Offline
Moparts proctologist

Registered: 02/15/10
Posts: 15242
Loc: Granite Bay CA
That is not a hard to find K member. All 318 and 383 cars used it from 70-72. I am told the 440 cars had that unique skid plate but was otherwise identical.

Top
#2405826 - 11/19/17 03:37 AM Re: Broke my K Frame [Re: mickm]
Frankenduster Offline
Moparts proctologist

Registered: 02/15/10
Posts: 15242
Loc: Granite Bay CA
Like this one.


Attachments
40 440 K #.jpg

70 440 K.jpg



Top
#2405854 - 11/19/17 07:46 AM Re: Broke my K Frame [Re: mickm]
GTSDave Offline


Registered: 01/19/03
Posts: 3024
Loc: Richmond, Tx. (Houston)
I supported my engine and pulled the K-Member to repair and reinforce at the steering box mounts when I broke a steering box. Made it much easier to repair it, and there was no guessing if I had repaired all the cracks. Included a pic with the k-member out. By the way this was with a low deck, 440-1 heads and the original pro parts headers. Have since gone to a custom set of headers.

-Dave


Attachments
Critter K Member off.jpg


_________________________
PLEASE Pray for our brothers and sisters in harms way.

GTS Registry

Top
#2405908 - 11/19/17 10:51 AM Re: Broke my K Frame [Re: mickm]
CKessel Offline
enthusiast

Registered: 01/13/10
Posts: 357
Loc: Los Osos, Ca
The 70 unit is unique as it has the sway bar through the k but the steering box angle is the same as the earlier years. 71-2 the box angle changed and to use it you need the center link from those two years too then you should be ok. 71 on is the same as the e-bodies from what I've found out. Found this out when putting a 70 unit in my 65 Coronet.
_________________________
Carl Kessel

Top
#2405914 - 11/19/17 11:01 AM Re: Broke my K Frame [Re: mickm]
Silver70 Offline
I Live Here

Registered: 02/01/03
Posts: 18067
Loc: Rust Belt, SW PA
Late 69 would have the same indents in the k-frame for the 70 sway bar, just no holes drilled which would be easy to do. I have a 71 k-frame in my 69 belevedere... has no issues with it.
_________________________
68 Road Runner, 69 Belvedere, 71 Challenger Vert
340 barracuda, 01 Ram CTD, 95 Ram, 04 Ram, 85 Daytona turbo Z
99 Trans Am, 66 GTO, 06 Magnum RT AWD

Top
#2406008 - 11/19/17 03:11 PM Re: Broke my K Frame [Re: mickm]
cudaman1969 Offline
master

Registered: 01/25/04
Posts: 4318
Loc: fredericksburg,va
Find another k frame, if the mount is broken, what else?

Top
#2406015 - 11/19/17 03:22 PM Re: Broke my K Frame [Re: cudaman1969]
pittsburghracer Online   work
Slowride

Registered: 02/02/05
Posts: 12946
Loc: PA.
Take a good look at your transmission tailshaft while your are under there.
_________________________
1970 Duster
Edelbrock headed 408
6.143@110.89 mph
9.73@135.05 mph shifting at 6700 RPM
422 Indy headed small block
6.001@113.27mph
9.44@138.23

Untitled by John Cadamore, on Flickr





Top
#2406016 - 11/19/17 03:28 PM Re: Broke my K Frame [Re: pittsburghracer]
HotRod20 Offline
mopar

Registered: 07/26/04
Posts: 690
Loc: Michigan
I agree with Pittsburghracer.....check your tail shaft while you're under there....great advice!
HR20

Top
#2406034 - 11/19/17 04:43 PM Re: Broke my K Frame [Re: HotRod20]
mickm Offline
master

Registered: 07/26/06
Posts: 4073
Loc: California
Originally Posted By HotRod20
I agree with Pittsburghracer.....check your tail shaft while you're under there....great advice!
HR20


Ugh..!

Will do...
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2406118 - 11/19/17 08:04 PM Re: Broke my K Frame [Re: mickm]
RUNCHARGER Online   content
I Live Here

Registered: 01/20/03
Posts: 15575
Loc: Chilliwack B.C. Canada
Good idea: I would expect the left mount to want to pull up, not so much the right one. I wouldn't worry about a new K-member, welding this one shouldn't take more than 30 minutes and you have to pull it out anyway.
_________________________
Sheldon

Top
#2406137 - 11/19/17 08:34 PM Re: Broke my K Frame [Re: RUNCHARGER]
mickm Offline
master

Registered: 07/26/06
Posts: 4073
Loc: California
Originally Posted By RUNCHARGER
Good idea: I would expect the left mount to want to pull up, not so much the right one. I wouldn't worry about a new K-member, welding this one shouldn't take more than 30 minutes and you have to pull it out anyway.


Yea, my plan is to weld it, and just reinforce all the other welds.
_________________________


"the orange fun car" 540 Hemi 4 spd 3:54 dana
1 of 1 - only FK5 70 Road Runner that used to be a 383 auto now a 540 Hemi Six-Pak 4 spd in existence

Top
#2406185 - 11/19/17 10:57 PM Re: Broke my K Frame [Re: mickm]
71rm23 Offline
top fuel

Registered: 01/04/08
Posts: 2314
Loc: None
If it can be welded, fine. If needing another K, get a hold of Moparmarks member here. Either way, I'd consider a torque strap for the final install as well.

Top
#2406227 - 11/20/17 03:05 AM Re: Broke my K Frame [Re: mickm]
astjp2 Offline
master

Registered: 01/18/11
Posts: 4158
Loc: Utah and Alaska
When you pull the kframe, take it to a machine shop and have it hot tanked, less things to burn when welding. Tim
_________________________
1941 Taylorcraft
1968 Charger
1994 Wrangler
1998 Wrangler
2008 Kia Rio
2017 Jetta

I didn't do 4 years and 9 months of Graduate School to be called Mister!

Top
#2406529 - 11/20/17 06:57 PM Re: Broke my K Frame [Re: mickm]
Frankenduster Offline
Moparts proctologist

Registered: 02/15/10
Posts: 15242
Loc: Granite Bay CA
That is a great idea. I should do that next time.

Top
Page 1 of 3 1 2 3 >

Advertisement
Forum Stats
25,379 Registered Members
32 Forums
191,044 Topics
2,230,247 Posts

Most users ever online: 1,424 @ 06/20/18 07:18 PM
Moparts Newest Topics
When someone oils down the track
by bigdad
07/16/18 12:01 PM
3614433 Gen 2 Hemi Heads Specs
by 360tripleblack77
07/16/18 10:33 AM
Replacing Windshield in '68 Barracuda
by Erik
07/16/18 10:02 AM
B-Body Automatic Brake Pedal 66 and up the same or different
by vinnyd76
07/16/18 09:46 AM