Moparts Forums >> Moparts Question and Answer

451Mopar
mopar addict


Reged: May 19 2008
Loc: Aurora, Colorado
Re: Mopar electronic ignition issues........troubleshoo
      Wed Sep 02 2009 11:55 PM

If you are saying it won't fire/start while cranking, but starts once you release the key, then the problem is voltage drop through the battery cables / bad ground connection(s). Or a defective ignition switch.
Consider this scenario: The battery ground wire/connection has 0.1 Ohm of resistance. At 10-amps of current flow, that is a 1 Volt drop, so if you measured from the chassis/engine ground to the battery positive terminal, the voltage would read 1-volt less than the actual battery voltage.

When cranking the starter, you might be pulling 70+ Amps or more, this would reduce the voltage at the ignition module/coil by 7 volts!

This is why when you release the key from the start position, it removes the high current load to the starter, and results in nearly full voltage being avilable at the ignition box/module/ignition coil to fire the ignition.

The fix is to have good battery cables and good clean low resistance connections.

Post Extras Print Post   Remind Me!     Notify Moderator


Entire topic
Subject Posted by Posted on
* Mopar electronic ignition issues........troubleshooting Robbins Wed Sep 02 2009 08:39 PM
. * * Re: Mopar electronic ignition issues........troubleshooting menomoniemopars   Sat Sep 05 2009 09:49 AM
. * * Re: Mopar electronic ignition issues........troubleshooting MoparforLife   Sat Sep 05 2009 10:39 AM
. * * Re: Mopar electronic ignition issues........troubleshooting NachoRT74   Sat Sep 05 2009 10:57 AM
. * * Re: Mopar electronic ignition issues........troubleshooting menomoniemopars   Sat Sep 05 2009 01:02 PM
. * * Re: Mopar electronic ignition issues........troubleshooting Robbins   Sat Sep 05 2009 01:07 PM
. * * Re: Mopar electronic ignition issues........troubleshooting Robbins   Mon Sep 07 2009 12:06 PM
. * * Re: Mopar electronic ignition issues........troubleshooting RapidRobert   Sun Oct 04 2009 07:25 AM
. * * Re: Mopar electronic ignition issues........troubleshooting Robbins   Mon Sep 07 2009 12:33 PM
. * * Re: Mopar electronic ignition issues........troubleshooting 451Mopar   Mon Sep 07 2009 02:35 PM
. * * Re: Mopar electronic ignition issues........troubleshooting Robbins   Mon Sep 07 2009 07:50 PM
. * * Re: Mopar electronic ignition issues........troubleshoo 451Mopar   Mon Sep 07 2009 11:02 PM
. * * Re: Mopar electronic ignition issues........troubleshoo Robbins   Tue Sep 08 2009 02:09 PM
. * * Re: Mopar electronic ignition issues........troubleshoo 451Mopar   Wed Sep 02 2009 11:55 PM
. * * Re: Mopar electronic ignition issues........troubleshoo Robbins   Sat Oct 03 2009 11:28 PM
. * * Re: Mopar electronic ignition issues........troubleshoo 72 RR DUDE   Sun Oct 04 2009 05:17 AM
. * * Re: Mopar electronic ignition issues........troubleshoo Robbins   Thu Sep 03 2009 07:55 AM
. * * Re: Mopar electronic ignition issues........troubleshooting RapidRobert   Wed Sep 02 2009 09:02 PM

Extra information
23 registered and 80 anonymous users are browsing this forum.

Moderator:  moparts, SanityLost, tboomer, LTDan, 70Cuda383, Hotwheelsjr, not_a_charger, Eric, Al_Alguire 



Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 3849

Rate this thread

Jump to

Contact Info | Privacy statement main index

Powered by UBB.threads™ 6.5.2